Troubleshoot: VPP Apps

This article is for troubleshooting Volume Purchase Program (VPP) installs. We will use an example of installing Slack on macOS.

General Troubleshooting

All of the following commands can be run using the Terminal app on the device, or via JumpCloud Commands, to better understand an application's current status.

  • Check if there is an app store receipt:
    ls /Applications/slack.app/Contents/_MASReceipt
    if there is a receipt: receipt
    if no receipt: ls: /Applications/Slack.app/Contents/_MASReceipt: No such file or directory
  • Show if the app is VPP licensed or from the App Store:
    mdls /Applications/Slack.app/ -name kMDItemAppStoreReceiptIsVPPLicensed
    when installed by a user via App Store: kMDItemAppStoreReceiptIsVPPLicensed = 0
    when installed by an admin via VPP: kMDItemAppStoreReceiptIsVPPLicensed = 1
    when installed by a user via PKG or drag and drop: kMDItemAppStoreReceiptIsVPPLicensed = (null)
  • Output a text file to show install attempts for this app:
    log show --predicate 'eventMessage contains ""' --info --last 1d > ~/Desktop/systemlogs.txt
    If the command was sent by app was not installed you can check Apple unified logs in Console.app.

To identify which apps are managed on a device locally:

  • On a Mac, go to System Settings > General > Device Management > MDM Enrollment Profile > Managed Apps.
  • On iOS, go to Settings > General > VPN & Device Management > MDM Enrollment Profile > Apps.

Troubleshooting Specific Errors

Error: Unable to retrieve managed software data. Please refresh the page and try again.

Symptoms

The following error appears in the Admin Portal when making changes to VPP apps in Software Management:

Unable to retrieve managed software data. Please refresh the page and try again.

Cause

This error usually occurs because of a synchronization problem with your VPP tokens, even if the VPP token has not yet expired.

Resolution

To resolve, renew your VPP tokens:

  1. Go to DEVICE MANAGEMENT > MDM.
  2. Select the VPP tab.
  3. Select the VPP token for your location and click Actions.
  4. To renew your token for one year, choose Renew Configuration.
  5. In the Renew Apple’s VPP page, under Sign in to Apple, click sign in to Apple Business Manager to download a token for your MDM server. If you have an education account, click sign in to Apple School Manager.
  6. In ABM or ASM, select your account at the bottom-left, then select Preferences from the pop-up menu, then select Payments and Billing from the main panel.
  7. Under My Server Tokens, find the token for your location, then click on it to download the VPP token.
  8. Click Save to save the token locally.
  9. Click Replace if your token already exists in the same folder.
  10. In the JumpCloud Admin Portal, under Upload the token to JumpCloud, click Browse or drag and drop the server token for your MDM server. You can only upload a token once.
  11. Click complete. Your organization’s token appears in the VPP tab. The token is valid for one year.
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